دسته بندی : فریم ورک LARAVEL

آموزش آپدیت لاراول از 5.5 به 5.7

برای اینکار شما باید اپلیکیشنتون طبق کانونشن های لاراول کد نویسی شده باشه تا به مشکل در هنگام آپدیت شدن بعضی از dependency ها نداشته باشید و به ترتیب کارهای زیر رو انجام بدید :

  • یک بک آپ از کل پروژه لاراولتون بگیرید
  • فایل composer.lock و پوشه vendor رو حذف کنید
  • ویرایش فایل composer.json میتونید آخرین ورژن لاراول که الان ۵٫۷ هست رو قرار بدید
{
    ...
    "require": {
        "laravel/framework": "5.7.*",
    }
}

بعد از اینکار شما cmd رو داخل روت پروژه باز میکنید و دستور زیر رو در کنسول بنویسید

composer install

تجربه شخصی : در بعضی مواقع بعد از آپدیت لاراول خطا های از طرف فایل web.php پروژه به من میداد بیشتر در قسمت namespace با ریز شدن داخل این قسمت دیدم که من در روت برای تعریف گروپ نیم اسپیس ها به صورت زیر عمل میکنم

Route::namespace("\\Dashboard\\")

تو این مواقع لاراول به من ارور میداد و namespace کنترل من رو نمیشناخت به خاطر \\ بود و بعد از حذف اون مشکل حل شد .

در مواردی دیگه در قسمت event model ها در متد static boot دیده شده اگر از ()parent::boot استفاده نشه لاراول model شما رو نمیشناسه


0| از0رای

مطالب مشابه


0 دیدگاهافزودن